Foodsoft packaging: libssl1.0-dev and Ruby 2.3.8

So, I’ve discovered in my packaging efforts that Ruby 2.3.x requires the old libssl-1.0-dev (I’m on Debian Stretch).

That conflicts with the ususal libssl-dev which most other packages need and require. I’m using this solution:

So, I am wondering about the compatibility with Ruby 2.3. Is it possible to use a more recent version of Ruby?

That would help me alot to know if anyone has tried it before. Or if it can be supported in some way.


I don’t remember precisely, but I should think using a recent Ruby-version is fine. You might encounter some warnings, though.
We also have some dependencies that don’t work with newer versions, which may not work perfectly with newer Ruby versions (rails-settings-cached).
On my development machine, I use Ruby 2.4.

  • Willem

Thanks! I am now using 2.4.6 successfully :slight_smile: