docker on foodsoft 4.6 - problem

Great work! I am getting much farther now, although not quite through yet.

After all the package fetching and installing, docker-compose gives an error

There was an error while trying to write to /home/app/src/Gemfile.lock. It is
likely that you need to grant write permissions for that path.
Service ‘foodsoft’ failed to build: The command ‘/bin/sh -c bundle config build.nokogiri “–use-system-libraries” && bundle install -j 4’ returned a non-zero code: 23

Full output is here

I am Win10, the drives are shared with Docker.

Hi Sven,

Thanks for reporting back! The current docker image expects uid 1000 for permissions, which works for many default Linux installations, but apparently not for Windows. Sorry it bit you, a proper fix would be something like but that hasn’t been picked up yet. If you’d like to have a try, welcome :wink: (*)

  • Willem

(*) An alternative option would be to do everything as root, but that is not something I’d like from a security standpoint (like checking out PRs and testing them).