Development setup with Docker: errors

I just tried to get Foodsoft running locally via Docker (Ubuntu) and ran into the following problems:

  • docker-compose -f docker-compose-dev.yml up -d mariadb
    led to the error docker.errors.DockerException: Install paramiko package to enable ssh:// support
    I noticed that this is a problem with compose v1 (I was using docker-compose version 1.29.2) and tried compose v2, replacing “docker-compose” with “docker compose”. Then the first command worked.
  • docker compose -f docker-compose-dev.yml run --rm foodsoft bundle install
    Again using compose v2, I got the following error:
    Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: exec: "./": stat ./ no such file or directory: unknown
    I was using shell in the Foodsoft directory.
    How should I solve this?

Tested with docker-compose 1.29.2 I have no such problems on Debian bullseye.

Maybe it’s to obvious: does exists in the same path you’re running docker-compose?

Yes, as I wrote I was running it in the Foodsoft path where the was as well.
But note: I did not run docker-compose but docker compose (v2) because of the problem I mentioned above.

did the docker context stuff we’ve talked about work you? :slight_smile:
making docker-compose v2 work could be another issue for the tracker …